Ticket #1256 (new task)

Opened 5 years ago

Last modified 4 years ago

Jacks fails to remove exclusive='true' from existing RSpecs

Reported by: sedwards Owned by:
Priority: major Milestone: GEC 23
Component: jacks Version:
Keywords: Cc: duerig@flux.utah.edu
Dependencies:

Description (last modified by sedwards) (diff)

I loaded an existing RSpec with a Raw PC into Jacks, then changed the node type of the Raw PC to be an OpenVZ container.

The exclusive='true' tag remained on the node that had been a Raw PC. This resulted in a topology with an OpenVZ container on an exclusive node. (When I originally reported the bug I couldn't get the RSpec to reserve at all. Now I am able to reserved but the exclusive is still set to true.)

Jacks should ensure that nodes that are shared (xen, OpenVZ) do not have exclusive set to true.

Attached please find example before and after RSpecs.

Attachments

single.rspec Download (0.5 KB) - added by sedwards 5 years ago.
Before RSpecs
single_after.rspec Download (0.6 KB) - added by sedwards 5 years ago.
After RSpec

Change History

Changed 5 years ago by sedwards

Before RSpecs

Changed 5 years ago by sedwards

After RSpec

Changed 5 years ago by sedwards

  • description modified (diff)

Attached

Changed 5 years ago by tmitchel

There was discussion between Niky and Sarah and it's not yet clear what the correct behavior should be.

Niky:

Just to point out here that although I understand why this is confusing,
Jacks might be actually doing the right thing, since you
can get an exclusive XEN or OpenVZ VM and some peopler (very few)
have used this. In flack I believe there is a flag for exclusive.
If we make it the case that a raw PC that was made into an OpenVZ is
always exclusive=false then there is no way to get an exclusive OpenVZ.

We might want to decide that you can not get an exclusive VM, I
just want us to be aware of the decision.

Sarah:

So the first time I tried it I couldn't reserve anything at all (I got
an error about an invalid topology). I tried a second time with a
slightly different setup (after sending the email) and I was able
to reserve resources.

I'm not sure what the right thing is here.

When they decide what the correct behavior is, they will update this ticket.

Changed 4 years ago by ahelsing

  • milestone changed from GEC 22 to GEC 23
Note: See TracTickets for help on using tickets.